°

tp5.1安装报错解决方案

2019年课程规划及价格说明


PHP实战视频教程大全

第一次使用tp5.1的时候你可能会遇到运行出错的提示:

Parse error: syntax error, unexpected '.', expecting '&' or variable (T_VARIABLE) in F:\wamp\www\tp51\thinkphp\library\think\Loader.php on line 391

这是因为你的php版本太低了,不符合tp5.1的要求

切换一下php的版本到php7就可以了

目前基本上我们所使用的集成环境都已经支持php7了

比如国内常用的phpstudy,这款软件很好用,但是我们并不是经常使用,因为习惯使用wamp这是一个

比较老牌的集成环境了,好多年了,但是老版本升级新版本稍微会有问题,如果你没有比较重要的站点

建议你可以卸载旧的wamp重新安装新的版本,支持php7的版本,因为你手动升级版本的话会造成连带的

phpmyadmin受到影响,虽然是可以解决的,但是还是比较繁琐的

再有一个不错的集成环境就是mamp了,也是好用的。

打赏
  喜欢